IonCube Loader is a software instrument, which is necessary to run files which are encrypted with ionCube PHP Encoder. The latter is an application employed to make PHP code human unreadable, to protect it from reverse engineering and illegal use. A great number of script-driven apps, in particular discussion boards, cms and e-commerce solutions are encrypted with ionCube PHP Encoder, so if you purchase a script and you notice that ionCube is one of the hosting environment requirements, you have to ensure that your web hosting server has the tool pre-installed. While it's not that hard to install it when you have your own server, it's close to impossible to do that on a shared hosting server since the PHP environment will have to be precompiled and all of the clients on the server shall be affected.

IonCube in Cloud Hosting

IonCube Loader is provided with all cloud hosting plans that we supply, so any time you need it in order to install and run a script app which needs it, you can enable it with a single click from the Advanced area of the Hepsia Control Panel. Because you'll be able to switch the PHP release that is active for your account from the same section, you will need to activate the instrument for each new version which you set. If you're more skillful, you will be able to employ a php.ini file in a domain or subdomain folder and set the PHP version and the status of ionCube Loader for this particular site only, without affecting the whole account. This way you'll be able to manage both new and older script applications for multiple sites in the same account - something that you can't do with various other hosting providers available on the market.

IonCube in Semi-dedicated Servers

If you purchase a semi-dedicated server plan from our company, you will be able to employ any script-driven application which requires ionCube Loader since the tool is installed on all of the servers that are a part of our innovative cloud hosting platform. Furthermore, we support several releases of PHP, and if you switch from PHP 4 to 5.2 or 5.3, for instance, you can activate ionCube for this particular version with just a click in your Hepsia Control Panel. Our system will remember your choice, so if you switch back to the earlier version of PHP, the instrument will already be active. For more tech-savvy users, we also offer the option to select the PHP version and whether ionCube will be active or not for a particular domain name without altering the settings for the entire website hosting account. This is done by placing a php.ini file in a domain folder with a few lines of code.